Excel – Planifier un projet

Contexte

Vous planifiez un projet dans Excel et avez prévu plusieurs colonnes pour les dates liées aux tâches du projet (date de début de la tâche, date de fin de la tâche et date de suivi). Étant donné que les tâches ne sont pas toutes terminées (certaines cellules « date de fin » sont vides), vous souhaitez pouvoir calculer la différence entre la date de début et la date de suivi mais seulement en l’absence d’une date de fin. Vous avez prévu d’entrer les dates manuellement; seule la différence entre les dates doit être calculée.

Solution

Utilisez la fonction* DATEDIF, sachant que dans mon exemple :

  • Le nom de la tâche est en A2
  • La date de début de la tâche est en B2
  • La date de fin (s’il y en a une) est en C2
  • La date de suivi prévue est en D2
  • La formule de calcul se trouve en E2
    =SI(C2=““;DATEDIF(B2;D2;“d“);DATEDIF(B2;C2;“d“)) &“ jours“

Autrement dit : Si la cellule C2 est vide, Excel doit calculer la différence entre B2 et D2. Cette différence doit être exprimée en jours (argument “d”). Si C2 n’est pas vide, Excel doit calculer la différence entre B2 et C2. Cette différence doit également être exprimée en jours. L’indication “& jours“ à la fin de la formule fera apparaître le mot « jours » dans le résultat du calcul afin d’éviter une mauvaise interprétation du résultat :DateDifetSI

* La particularité de cette fonction est qu’elle ne figure pas dans la liste officielle des fonctions d’Excel ;)

It's only fair to share...Share on LinkedIn
Linkedin
Share on Facebook
Facebook
Tweet about this on Twitter
Twitter
Email this to someone
email
Print this page
Print

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *