Excel – Utiliser la fonction SI(ESTVIDE)

Contexte

Vous disposez d’un fichier Excel contenant par exemple des adresses de contacts internes (facultés, services, unités…). Dans votre tableau, une colonne est prévue pour contenir les URL des contacts (colonne B). Or, pour certains d’entre eux, les URL sont inconnues et vous aimeriez, dans ce cas, qu’une URL « générique » soit utilisée (par ex. www.unil.ch). Il faut donc insérer dans une nouvelle colonne (colonne C), une fonction qui complèterait automatiquement les URL inexistantes par l’URL générique laquelle a été saisie en A1.

Solution : utiliser la fonction SI(ESTVIDE)

  • Créez une colonne supplémentaire par ex. URL_calculée
  • En C3, saisissez la fonction suivante : =SI(ESTVIDE(B3);T($A$1);T(B3)) autrement dit si B3 est vide, alors insérer le texte se trouvant en A1, sinon insérer le texte se trouvant en B3. Dans la formule de calcul, remarquez que j’ai transformé A1 en une adresse absolue (grâce aux touches fn + F4 permettant d’insérer des $)
  • Recopiez cette formule de calcul sur les autres cellules de la colonne C