Excel – Aérer les formules de calcul

Contexte

Vous avez ouvert un tableau Excel et certaines formules de calcul vous semblent difficile à déchiffrer (surtout si elles ont été faites par quelqu’un d’autre). Vous aimeriez simplement rendre ces formules plus lisibles en séparant les éléments qui les constituent.

Solution : aérez vos formules

  • Tout d’abord, agrandissez la zone dédiée à la barre de formule (nécessaire seulement sur Mac)
  • Placez votre curseur dans la formule à l’endroit souhaité
  • Appuyez sur les touches Cmd + Ctrl + Enter (Mac) ou sur les touches Alt + Enter (PC); vous obtenez alors un saut de ligne
  • Poursuivez ainsi en insérant des saut de ligne aux endroits souhaités
  • Insérez éventuellement des espaces blancs pour séparer les parenthèses :

La formule :

=SI(SOMME(D23-C23;F23-E23;H23-G23)=0;””;SOMME(D23-C23;F23-E23;H23-G23))

devient :

=SI(
SOMME(D23-C23;F23-E23;H23-G23)
=0;””;
SOMME(D23-C23;F23-E23;H23-G23) )

Les sauts de ligne et les espaces blancs sont sans effets secondaires indésirables sur le résultat de la formule.

It's only fair to share...Share on LinkedIn
Linkedin
Share on Facebook
Facebook
Tweet about this on Twitter
Twitter
Email this to someone
email
Print this page
Print

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *