Excel – Utiliser la fonction SI(ESTVIDE)

Contexte

Vous disposez d’un fichier Excel contenant par exemple des adresses de contacts internes (facultés, services, unités…). Dans votre tableau, une colonne est prévue pour contenir les URL des contacts (colonne B). Or, pour certains d’entre eux les URL sont inconnues et vous aimeriez, dans ce cas, qu’une URL « générique » soit utilisée (par ex. www.unil.ch). Il faut donc insérer dans une nouvelle colonne (colonne C), une fonction qui complèterait automatiquement les URL inexistantes par l’URL générique (se trouvant en A1).

Solution : utiliser la fonction SI(ESTVIDE)

  • Créez une colonne supplémentaire par ex. URL_complété
  • En C3, saisissez la fonction suivante : =SI(ESTVIDE(B3);T($A$1);T(B3)) autrement dit si B3 est vide, alors insérer le texte se trouvant en A1, sinon insérer le texte se trouvant en B3. Remarquez que j’ai transformé A1 en une adresse absolue (à l’aide des $)
  • Recopiez cette fonction sur les autres cellules de la colonne C

SiEstVide

It's only fair to share...Share on LinkedIn
Linkedin
Share on Facebook
Facebook
Tweet about this on Twitter
Twitter
Email this to someone
email
Print this page
Print

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *